fluently - Call Pickup – Incident details

Call Pickup

Resolved
Major outage
Started about 2 months agoLasted about 2 hours

Affected

Call-Infrastructure

Major outage from 9:50 AM to 11:22 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.